博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
poj 3259
阅读量:7011 次
发布时间:2019-06-28

本文共 3087 字,大约阅读时间需要 10 分钟。

                                                       
                                                     
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 28499   Accepted: 10302

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,
F.
F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively:
N,
M, and
W
Lines 2..
M+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: a bidirectional path between
S and
E that requires
T seconds to traverse. Two fields might be connected by more than one path.
Lines
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: A one way path from
S to
E that also moves the traveler back
T seconds.

Output

Lines 1..
F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

23 3 11 2 21 3 42 3 13 1 33 2 11 2 32 3 43 1 8

Sample Output

NOYES

题意:John的农场里field块地,path条路连接两块地,hole个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。

思路:bellman_ford。由于存在负权边,Dijkstra便不能用了。题目简化下,就是看图中有没有负权环,有的话John可以无限次走这个环,使得时间一定能得到一个负值。所以有的存在负环话就是可以,没有的话就是不可以了。

 

#include <iostream>

#include <cstdio>
using namespace std;
#define fMax 505
#define eMax 5205
#define wMax 99999

struct A

{
    int sta,end,time;
}edge[eMax];

int point_num,edge_num,dict[fMax];

bool bellman_ford()

{
   for(int i=2;i<=point_num;i++)
      dict[i]=wMax;
   for(int i=1;i<=point_num;i++)
   {
       bool fals=0;
       for(int j=1;j<=edge_num;j++)
       {
           int v=edge[j].sta;
           int u=edge[j].end;
           int w=edge[j].time;
           if(dict[v]>dict[u]+w)
           {
               dict[v]=dict[u]+w;
               fals=1;
           }
       }
       if(!fals)
       break;
   }
   for(int j=1;j<=edge_num;j++)
       {
           int v=edge[j].sta;
           int u=edge[j].end;
           int w=edge[j].time;
           if(dict[v]>dict[u]+w)
           {
               dict[v]=dict[u]+w;
               return 0;
           }
       }
       return 1;
}

int main()

{
    int farm;
    scanf("%d",&farm);
    while(farm--)
    {
        int field,path,hole;
        scanf("%d %d %d",&field,&path,&hole);
        int s,e,t,k=0;
        for(int i=1;i<=path;i++)
        {
            scanf("%d %d %d",&s,&e,&t);
            edge[++k].sta=s;
            edge[k].end=e;
            edge[k++].time=t;
            edge[k].sta=e;
            edge[k].end=s;
            edge[k].time=t;
        }
        for(int i=1;i<=hole;i++)
        {
            scanf("%d %d %d",&s,&e,&t);
            edge[++k].sta=s;
            edge[k].end=e;
            edge[k].time=-t;
        }
        point_num=field;
        edge_num=k;
        if(!bellman_ford())
        printf("YES\n");
        else
        printf("NO\n");

    }

    return 0;

}

转载于:https://www.cnblogs.com/ngyifeng/p/3709635.html

你可能感兴趣的文章
logback+slf4j作为日志系统
查看>>
Global Mapper如何加载在线地图
查看>>
黄聪:Wordpress中JQUERY链接平移效果
查看>>
反向代理服务器
查看>>
SharePoint 2010 网站备份还原简单介绍
查看>>
WebViewJavascriptBridge的基本原理
查看>>
IIS7 配置 PHP5.6
查看>>
Ubuntu 14.04 安装 boost 1_57_0
查看>>
Thread类的join()方法
查看>>
二叉树的定义与前序、中序、后序遍历
查看>>
Laravel学习--关于Relation的坑
查看>>
mysql jdbc性能优化之mybatis/callablestatement调用存储过程mysql jdbc产生不必要的元数据查询(已解决,cpu负载减少20%)...
查看>>
Q_DECLARE_PRIVATE与Q_DECLARE_PUBLIC
查看>>
springboot数据库连接池使用策略
查看>>
eclipse定制化配置调优、初始化配置指南、可以解决启动慢等问题
查看>>
react实现多行文本超出加省略号
查看>>
回调函数
查看>>
DORIS-软件网址
查看>>
单例模式
查看>>
SICP 习题 (1.10)解题总结
查看>>